Clawpack インストールメモ

pip から1行でインストール

Quick Installation of all packages with pip に記載の通り.

pip install --src=$HOME/clawpack_src --user -e \
    git+https://github.com/clawpack/clawpack.git@v5.8.2#egg=clawpack-v5.8.2 \
    --use-deprecated=legacy-resolver

ただしこれエラーが発生しても問題がわかりにくいし,大体うまくいかない.
ソースのダウンロードとインストールを分けた方が無難.

ソースをダウンロード後に pip

まずは GitHub の Clawpack リポジトリの Releases から自分のほしいバージョンの tar.gz を拾ってきて展開する.
clone してもよいがバージョン固定のほうが余計なものがついてこなくてよい.
その後は展開したディレクトリの中で pip install をする.

wget https://github.com/clawpack/clawpack/releases/download/v5.7.1/clawpack-v5.7.1.tar.gz # ダウンロード
tar zxvf clawpack-v5.7.1.tar.gz # ファイルの解凍
cd clawpack-v5.7.1 # 解凍されたフォルダ(ディレクトリ)に移動
pip install --user 'setuptools<61' # エラー回避のため一旦 setuptool をダウングレードする
pip install --user -e . # インストール

Python の setuptool パッケージの最新バージョンを使うとエラーが発生してしまうため,一度バージョンを落とす必要がある.


インストール後は CLAW と FC の環境変数設定を忘れないように.


Front page   Edit Diff Attach Copy Rename Reload   New List of pages Search Recent changes   Help   RSS of recent changes
Last-modified: 2022-06-28 (Tue) 05:50:01 (41d)